AMP Light on, Alternator Charging

I started my 67 today for the first time in about a month. Last time I drove it, all was good.
Battery was a little low so I put the charger on it for a little while.
When I started it, the AMPS light stayed on. I grabbed a volt meter and, when I tested the battery voltage, it was ~14.3.
I checked the connector at the VR: all looked good.
When I unplugged the VR, the output from the alternator dropped to nominal battery voltage.
Plug the connector back in; output went back to 14.3.
I went ahead and got a new regulator, but I have the same results.
Before I put it in, I checked for voltages at the connector.
Battery voltage on the yellow wire.
Key off - No volts on the green “I” wire.
Key On - Battery volts on the green “I” wire.
With the engine running, I checked the volts at the green “I” wire connection. Found it still read ~5.6 volts.
With the differential of battery volts to this reading, the light will stay on, right??
All ground points are cleaned and shiny.
So, what am I missing??

Sounds like the alternator and regulator are working, but have you had the battery tested?

Did all of the metal connectors of the voltage regulator slide into the plastic slots of the wiring harness when you replaced it?

Yes, I checked that multiple times.
I’ve checked the voltages with the engine running and off at all the connector points.
I’m going to pull the alternator and have it tested, just to ease my mind, but it is charging very well.

Something is pulling the green/red wire down from 12V to 5.6V. When you remove it from the voltage regulator, did it go back up to 12V?

BTW, when you unplugged the voltage regulator, the alternator is now out of the circuit (not providing voltage) so what you read was battery voltage.

Yes, it went back to battery voltage.

Yup. Something is wrong and its pulling the voltage down on the green/red wire. Does this happen with the engine off and the key in RUN? If not, then that suggests the problem is in the VR/alternator. If it happens with the engine off, you have a wiring issue somewhere.

With the key on and the engine not running, the light is on anyway.
The only thing that turns it off is the application of ~12 volts on the “I” connector to balance the ~12 volts coming from the switch, effectively stopping current flow and keeping the light off.
I just don’t know why I’m not getting the right voltage or current from the “I” connection.

Was this always this way? Does your VR plug have all 4 pins filled or just 3? It should have 4.

Any chance that someone has tried to go to the voltage regulator to hook up an after market ignition (Pertronix etc?) Failing that I suspect that you have a poor connection on the back side of the alternator or a badly frayed wire in that harness. You will see 12 volts under no load with your meter, but under load, the voltage drops due to high resistance in the connection or the badly frayed wire.

No, it just happened since the last time I drove my car.
I have never had any issues with the charging system.
The last time I drove it, all was fine.
When I started it to move it out of the garage the other day is the first time that light has shown up.

To answer xr7g428, no, nothing new has been connected to the VR wiring.
I do have a Pertronix II ignition system, but that is all wired to new wiring I ran specifically for that system and it was done about 3 years ago.
I am going to check the wiring condition when I remove the alternator to have it tested.

1 Like

I took the alternator to have it tested.
I had to tell the boy at O’Reilly how to hook it up.
It passed with flying colors.
I started checking the wiring and found the Field connector at the alternator wasn’t making good contact.
I made a new connector for the Field stud now, All is right with the world again.

Thanks for posting the fix! And congratulations on getting back on the road.