Tachometer not working

Putting a 69 xr7 back together after engine replacement. Tachometer worked before with the last engine but now it doesn’t. Where should I start?

Was the ignition system changed or upgraded along with the engine replacement? Perhaps a compatibility issue. Otherwise I would check ground wires if the tach is totally inoperable.

There is no ground wire that has any effect on the tachometer.

I would check to make sure the tach is actually plugged in. The tachometer is in series with the ignition circuit when connected properly. If the engine runs but the tachometer doesn’t work it typically means the tachometer has been bypassed.

Nothing was upgraded or changed. Where does it plug in? Would it have anything to do with the dash to engine gauge feed wiring assembly?

The + wire to the coil is part of the engine guage feed harness so yes. The tachometer is plugged into the + wire from the ignition switch. The other wire from the tachometer plugs into the resistance wire under the dash that leads to the firewall. The underhood guage feed harness plugs in at the firewall to complete the crcuit to the coil +.

Question - does the engine run?

Here’s a picture of the rear ('68 XR7 added for clarity) of the instrument cluster. You can see the two wires coming out of the back of the tachometer. I have an MSD box. Upon removal, the second picture shows the feed wire that was just sandwiched between the plugs. In the background (out of focus) are the corresponding vehicle side mating plugs.

The OP has a '69 XR-7. His dash doesn’t look like that.

Yes it runs

The OEM tach connects to the main harness via a short 2 wire pigtail with a flat M/F bullet connector.

The tach is not part of the cluster electrically, it is part of the primary ignition circuit: Ignition ON → Tach → ‘pink’ resistor wire → + side of coil

If the car runs but tach does not work and you had the cluster out chances are some debris got in the movement. It doesn’t take much at all to stop the movement, they are more fragile than a clock.

Cluster hasn’t been out. Engine replaced.

Tearing into this wiring. Attached some pics. I see two different cluster feed harnesses. One has a plug and looks to go to the oil pressure sending unit and the temp sensor. Looks like the replacement harness for this piece has another wire that doesn’t appear to be part of mine. On the coil dist post mine has a black wire and a pink/white wire. On the battery post mine has what used to be black and blue I believe but part of the wire outer covering burned off just leaving the wire itself.

Sounds like power to your coil might be coming from somewhere other than the factory pink resistor wire from the tach. At the 3 terminal firewall connector, my engine harness has a red/green stripe wire that plugs into the pink resistance wire and goes to coil BAT terminal. The same firewall connector also has the white/red stripe oil sensor and red/white stripe temp sensor wires.

Edit - sorry, I gave you 70 wire colors. Not sure about 69.

So the tach never worked. Need to sort out what’s not stock, delete it, and then it probably works fine.

No the tach worked great before the engine replacement. It was flawless worked every time and now it doesn’t.

I am suspicious of the white/red wire going to the + or BAT side of the coil. That looks more like the oil pressure line (white/red). There could be a splice under the tape where the wire comes out of the loom.

If it is the proper wire, it will only have voltage when the key is in the RUN position; the white/red and red/white wires will have voltage with ACC or RUN positions of the key.

I would un-tape all of that wiring and see exactly what you have going on.
You might be surprised what you will find.

Or just toss the whole mess and install one of these:

Agree except he needs this one:

I have one of these but this will only fix part of the problem and doesn’t appear to have anything to do with the tach. That wire is on a different harness.

It’s not. The oil pressure wire is part of the harness that unplugs at the firewall. The harness that Royce linked in his post and has a different end. Car has oil pressure. The wire you’re referencing is part of another harness. I’ll get some updated pics.